I 've installed sqoop on a machine (sqoop-1.4.4.bin__hadoop-1.0.0.tar.gz from http://www.apache.org/dist/sqoop/1.4.4/). When I try to run "$SQOOP_HOME/sqoop help"or any other command for that matter,
I am receiving the following error:
Warning: $HADOOP_HOME is deprecated.
Exception in thread "main" java.lang.NoClassDefFoundError: org/apache/sqoop/Sqoop Caused by: java.lang.ClassNotFoundException: org.apache.sqoop.Sqoop at java.net.URLClassLoader$1.run(URLClassLoader.java: 202) at java.security.AccessController.doPrivileged(Native Method) at java.net.URLClassLoader.findClass(URLClassLoader.j ava:190) at java.lang.ClassLoader.loadClass(ClassLoader.java:3 06) at sun.misc.Launcher$AppClassLoader.loadClass(Launche r.java:301) at java.lang.ClassLoader.loadClass(ClassLoader.java:2 47) Could not find the main class: org.apache.sqoop.Sqoop. Program will exit.
I tried installing sqoop in other machines and it worked fine. But not in one particular machine I want :( I've set hadoop home path and also have sqoop home in classpath.
Could someone let me know where am I doing mistake?


Check Solution