I am having smartcard reader from Ingenico, trying to make it work on Ubuntu 12.4. 64bit
I have already installed pcsc lite and libusb and reader driver which isSCL01x Contactless Reader - driver.
The situation is when i plug the rader in my USB port, signal light is off on reader.
When i try to run pcscd i get his errors:
00000000 dyn_unix.c:37:DYN_LoadLibrary() /usr/local/lib/pcsc/drivers/SCLGENERIC.bundle/Contents/Linux/libSCLGENERIC.so.2.09: /usr/local/lib/pcsc/drivers/SCLGENERIC.bundle/Contents/Linux/libSCLGENERIC.so.2.09: wrong ELF class: ELFCLASS3200000096 readerfactory.c:996:RFInitializeReader() RFLoadReader failed: 0xFFFFFFFF8010001400000074 readerfactory.c:312:RFAddReader() SCL011G Contactless Reader [SCL01x Contactless Reader] (21161207200555) init failed.00000047 hotplug_libudev.c:391:HPAddDevice() Failed adding USB device: SCL011G Contactless Reader
when i run pcsc_scan:
PC/SC device scannerV 1.4.18 (c) 2001-2011, Ludovic Rousseau Compiled with PC/SC lite version: 1.7.4Using reader plug'n play mechanismScanning present readers...0: SCL011G Contactless Reader [SCL01x Contactless Reader] (21161207200555) 00 00
Fri Jan 17 03:27:45 2014Reader 0: SCL011G Contactless Reader [SCL01x Contactless Reader] (21161207200555) 00 00 Card state:
And nothing...
I tried also example with smartcardio package in java, and error is: no terminals, cardreader can not be found.When i run lsusb, there is my reader in device list marked as SCM Microsystem


Check Solution